Unlimited Wordpress themes, plugins, graphics & courses! Unlimited asset downloads! From $16.50/m
Advertisement
  1. Web Design
  2. jQuery
Webdesign

Tips Pantas: Berhati-hati Apabila Menggunakan Versi Slim dari jQuery

by
Difficulty:BeginnerLength:ShortLanguages:

Malay (Melayu) translation by Kaustina Nurul Ilmi (you can also view the original English article)

Dalam tips pendek ini, saya akan menerangkan apabila anda sepatutnya dan apabila anda tidak seharusnya menggunakan "versi ramping" jQuery. Untuk petua ini, saya akan menganggap bahawa anda sudah biasa dengan jQuery, atau sekurang-kurangnya telah mendengarnya.

Tonton Screencast itu

jQuery vs jQuery Slim

Untuk menggunakan jQuery, anda biasanya pergi ke https://jquery.com/download/ dan dapatkan satu pakej yang ditawarkan. Pada masa ini versi pengeluaran mampatan jQuery mempunyai fail besar 87Kb. Ini bukan jumlah yang besar, tetapi anda boleh menyimpan lebih daripada 17Kb dengan memilih versi pengeluaran termampat yang slim.

Apabila anda cuba mengoptimumkan prestasi, anda perlu mengambil setiap simpanan yang anda boleh, dan inilah yang dimaksudkan: versi langsing menjimatkan beban anda dengan menafikan ajax dan modul kesan.

Modul Ajax yang mungkin kurang digunakan daripada kedua-duanya. Ia mengandungi fungsi dan kaedah yang membolehkan kita memuatkan data tanpa perlu memuat semula halaman. Modul kesan bagaimanapun, lebih cenderung untuk dipaparkan di laman web anda; Ia mengandungi fungsi dan kaedah untuk animasi yang sering digunakan. animate() contohnya, fadein() dan fadeout(), hide(), show(), dan sebagainya. Jika anda pernah menggunakan jQuery, kemungkinan anda telah menggunakan salah satu kaedah ini.

Jadi itu termasuk mesej penting di sini: jika anda memerlukan salah satu kaedah atau fungsi yang terdapat dalam modul ajax atau kesan pada jQuery, gunakan versi penuh. Jika tidak, anda akan menyimpan dengan menggunakan versi jQuery tipis.

Berhati-hati dengan Bootstrappers!

Sekarang, akhirnya, sebab utama di sebalik tip pendek ini! Harus diingat bahawa Bootstrap 4 (versi kerangka terbaharu) menggunakan versi jQuery tipis. Oleh itu, jika anda membina dengan Bootstrap dan anda merancang untuk menambah interaktiviti tambahan yang bergantung kepada ajax atau kesan, sebaliknya anda harus memuatkan versi lengkap perpustakaan jQuery.

Saya harap ia boleh menyelamatkan anda dari sakit kepala!

Advertisement
Advertisement
Looking for something to help kick start your next project?
Envato Market has a range of items for sale to help get you started.